3

I'm currently programming an app with flutter and have already listed all the licenses I use from the packages on an individual license page in the Settings. The question I am now asking myself is do I have to add the license for Flutter and Dart too to this list?

Here is the link to the darts license: https://raw.githubusercontent.com/flutter/engine/master/sky/packages/sky_engine/LICENSE

Here is the link to the flutter license: https://github.com/flutter/flutter/blob/master/LICENSE

Here is the link to the page where I found the information: https://flutter.dev/docs/resources/faq#which-software-licenses-apply-to-flutter-and-its-dependencies

1
-1

No, as far as i know, you don't need to explicitly add these licenses. But if you want to be 100% safe i would just add them as it's not that much work for you to do.

3
  • 3
    Do you have any reason (links) why you think so? Jun 17 at 17:10
  • Hi! Welcome to SO. Answer should be assured. If you want to give an advice (not an answer) or you don't actually sure about the answer just write a comment. Comments will be available as soon as you gain little more reputation.
    – Mol0ko
    Jun 18 at 6:19
  • @Mol0ko alright thanks for pointing this out! No but neither Flutter nor Dart specify anything regarding licenses. Maybe just add this here: github.com/flutter/flutter/blob/master/LICENSE . This should be the only one you need regarding Flutter itself. If its really needed i cant say but adding it should not be the problem.
    – Dany Tulumidis
    Jun 18 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.