6

Long story short, I'm working on building the debian/copyright file for a massive package, and have ran into the following rather confusing phrase in the copyright header of one of the source code files:

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Seems straightforward, right? Welp, guess what. There is no GNU Lesser General Public License version 2.

There's the GNU Library General Public License version 2, and there's the GNU Lesser General Public License version 2.1. The two licenses are different.

So... what license is this code under anyway? On one hand, maybe the user thought "LGPL-2" referenced a "Lesser General Public License version 2" and put that there without verifying that the license they were naming really existed. On the other hand, perhaps the use of the word "Lesser" rather than "Library" indicates that they mean LGPL-2.1.

Thankfully, the escape clause "or (at your option) any later version" has been given here, so I can call it LGPL-2.1 if all else fails and I should still be close enough to right. But still, I'd like to know if I'm just missing something, or if this really is ambiguous.

4
  • 3
    You correctly draw attention to the rightsholders' confusion between Library GPL 2.0 and Lesser GPL 2.1+. However, short of asking the package's authors what was intended, I'm not sure what help you think we can offer. Moreover, since you don't link to the package in question we can't even do that. I'm not sure what answer you were hoping for? Or are you just looking for confirmation that there is confusion, and it's not yours?
    – MadHatter
    Sep 5 at 5:33
  • 2
    @MadHatter Correct, I was just looking for confirmation that there is confusion. I thought maybe there was something I was missing (like, maybe Lesser General Public License version 2 was just a generally accepted alternate name for LGPL-2 or something). If it matters, the package is distrho-ports, the file in question is github.com/DISTRHO/DISTRHO-Ports/blob/master/libs/juced/source/…. But this comment is exactly the answer I was hoping for, if you make it an answer I'll accept it. Sep 5 at 6:35
  • 1
    @ArrayBolt3 The directory you are referring to seems to have been copied from github.com/cpptest/cpptest/tree/master/src and in the root of cpptest the COPYING file says LGPL 2.1 (GNU Lesser General Public License Version 2.1). I suspect the reason that the source file(s) of cpptest say "GNU Lesser General Public License" but still "version 2" is probably because it was originally under the GNU Library GPL version 2, and then when it was upgraded to LGPL 2.1, one did a search/replace to 'patch' only the name in the source headers, i.e. "GNU Library" -> "GNU Lesser".
    – Brandin
    Sep 5 at 10:18
  • 1
    Maybe you can file it as a 'bug' in cpptest. Though it's a very minor thing, I know some devs may enjoy to fix little details like that (when time permits), while others might think this is a waste of time. In any case, the Answer provided gives you a solution to use it properly in any case.
    – Brandin
    Sep 5 at 10:22

1 Answer 1

7

Since you just want confirmation that you're seeing the issue correctly (and let's face it, we all need that at some time or another!), I can confirm my view that the rightsholders have conflated the naming schemes of two different versions of the LGPL, the GNU Library General Public License, version 2.0, and the GNU Lesser General Public License, version 2.1. If memory serves, the principal difference between the two is the name change, which was intended to stop people thinking that the licence was for libraries, and start them thinking that it was for less-copyleft-protected software.

Your comment that their designation of Lesser GPL v2.0+ allows you to unambiguously use it under Lesser GPL v2.1 (or, indeed, v3) seems an excellent way of sidestepping the problem of there being no Lesser GPL v2.0.

I don't think we can say any more than that here, and you've indicated that that's what you wanted to know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.